Page 1 of 1

jre version issue (?)

PostPosted: Fri May 02, 2014 10:41 am
by goffes
I'm afraid I need some help with the following issue:

Freeplane won't start anymore, possibly after a java update. The message is: "this application requires runtime environment 1.5.0"
Installed version: Java 7 (jre 1.7.0 update 55). Freeplane used to work with 7, possibly an earlier update.
Freeplane version 1.2.23 if I remember correctly.

for starters I reinstalled java 7 - no good
Reinstalled freeplane - no good
Installed freemind - didn't run either with the same message
Installed java 8 - no good
Installed jre1.5.0_10 - no good
Reinstalled freeplane once more - no good

Any ideas anybody?

jre.PNG
(38.83 KiB) Downloaded 253 times

Re: jre version issue (?)

PostPosted: Fri May 02, 2014 12:18 pm
by jonpolish
I too had difficulty with some programs, although not with Freeplane. Although reticent to do this, reducing the security settings for Java resolved the problems.

Jon

Re: jre version issue (?)

PostPosted: Fri May 02, 2014 10:26 pm
by boercher
It's important to find out which Java installation is actually used since it's obviously not the one you installed (at least one of those should have worked). This might depend on environment variables. Please create a new issue in Mantis with more detailed information, e.g. log file.

Volker

Re: jre version issue (?)

PostPosted: Mon May 05, 2014 6:57 am
by goffes
Solved my problem: found a batchfile freeplane.bat in the freeplane directory and executed that one. It resets some environment variables. It got freeplane started. After that, the executable runs OK again.

I'm not going to investigate how the environment variables became to be wrong all of a sudden.

Thanks for considering my problem.
Cheers.

Goffe.