Page 2 of 2

Re: Inline Images Script fails

PostPosted: Fri Jun 21, 2013 8:29 am
by rickenbroc
Hello quinbus,

Thank you for your screencast, it revealed all the information I needed.

I tried to reproduce the issue but to no avail. It works flawlessly on the different computers that I tried.
The error message is not raised by my script, but directly by freeplane.
I browsed the FP code source, but I did not find any reason why this error is raised : it should only when FP can not find the map filename.
I think that if you try to make a link with an other feature than insert inline image you should see the same error message when you click on that link.
Maybe is there a problem with your installation. If you don't mind, may you try to reinstall a brand new downloaded 1.3.5 version in a brand new folde too (I had issues when I just replacing files in the same folder) and tell me if you're still facing that pb ?
If yes, I'm afraid it will be beyond my computing skills.

Re: Inline Images Script fails

PostPosted: Fri Jun 21, 2013 12:42 pm
by quinbus
Rickenbroc,

Hmmmm. You are right!

When I open any map with any links using 1.3.5, I get the error. When I open these same maps with my installed copy (i.e., not a zipped preview copy but a copy installed via a traditional installer--if I remember it is 1.2.22), everything works fine (including the links created by your script).

I brought down a new copy of 1.3.5 and ran it from the unzipped folder it came in and encounter the same problem.

So, it isn't your script at all. My apologies for sending you off on what we in middle US sometimes call a "wild goose chase" (a fruitless search for something that can't be found).

And as for your computing skills, I think you are an amazing artist in the field!

Thanks again for your help and patience; I'll open a Mantis report on the error condition.

Q!

Re: Inline Images Script fails

PostPosted: Fri Jun 21, 2013 8:51 pm
by rickenbroc
I'm glad that we find out where it fails and we did not loose our time.
I have to confess that it would have been tricky otherwise.
The burden is now on someone else's shoulders :evil:

Re: Inline Images Script fails

PostPosted: Tue Apr 22, 2014 12:52 pm
by boercher
sorry for reviving such an old thread but is the problem fixed in the meanwhile? Please report in Mantis.

Volker

Re: Inline Images Script fails

PostPosted: Thu Apr 24, 2014 8:59 am
by jokro
Rickenbroc,
Please note PM and Mantis: https://sourceforge.net/apps/mantisbt/freeplane/view.php?id=2138
Regards
Jodi